Subscribe to
Posts
Comments
NSLog(); Header Image

WordPress 2.1 Due Soon, 2.0.6 Very Soon

WordPress 2.0.6 RC1 is now available with a few changes and improvements. Word on the street is that WordPress 2.1 is going to be out in early January.

I hope most of my installed plugins survive. They don't appear to be doing too many "bad" things, so I think I should be okay.

The (dv)3 plan is supposed to roll out today at MediaTemple, so I'm looking at moving The Sand Trap over very soon to WP 2.0.x, then to 2.1 perhaps before we even resume publication on January 8!

5 Responses to "WordPress 2.1 Due Soon, 2.0.6 Very Soon"

  1. Ooh! WP 2.1 is going to be good. I hope the Shuttle project makes it in.

    You can check all of your plugins for compatibility here. I checked a couple of mine, but I'm really not good enough to do a thorough check. I'm glad most of my plugins are still actively being developed.

  2. Mike said on December 21, 2006:

    Ooh! WP 2.1 is going to be good. I hope the Shuttle project makes it in.

    I don't. It will probably only require an update to "WP Tiger Admin," which in my opinion looks a heckuva lot better than the Shuttle project.

    Mike said on December 21, 2006:

    You can check all of your plugins for compatibility here. I checked a couple of mine, but I'm really not good enough to do a thorough check. I'm glad most of my plugins are still actively being developed.

    That page doesn't list compatible plugins - it just lists some guidelines. And I wasn't talking about my plugins - the ones I wrote - I was talking about the plugins I have installed.

    Still, the elimination of $table* means quite a few plugins will need an update: Democracy, Quoter, Optimal Title, Organizer, Text Control, Viper's Used Plugins, and perhaps WP-DB Backup.

  3. Ah, true. Shuttle is really only useful for those who use the default WP admin interface style. Maybe I'll give Tiger a try, that looks pretty nice.

    Oh, I know it doesn't list compatible plugins. I went through the code of a few plugins I rely on that aren't actively developed, and didn't see any code that would be incompatible.

    They do, however, link to a page that tracks WP plugin compatibility with 2.1. It appears that Democracy is on the "okay" list. Go figure.

  4. Mike said on December 21, 2006:

    It appears that Democracy is on the "okay" list. Go figure.

    It also says "Democracy 1.2." The Democracy plugin I have - and the version linked to on that page - is version 2.0.1 (currently).

    Democracy (with the wrong version #), Optimal Title, and WP-DB Backup are listed as "good." Quoter, Organizer, Text Control, and Viper's Plugins Used are not listed. I consider Quoter and Organizer essential, so I hope they're updated. Unfortunately, I've not heard back from either author.

  5. I also am really looking forward to these releases!

    With a small team, releases are very dependent on the health and availability of the team. Ryan has not been well and others have not been available.


Trackback URI | Comments RSS

Leave a Reply

Please abide by the comment policy. Valid HTML includes: <blockquote><p>, <em>, <strong>, <ul>, <ol>, and <a href>. Please use the "Quote Me" functionality to quote comments.