Subscribe to
Posts
Comments
NSLog(); Header Image

Mail in Mountain Lion and Replying from the Proper Account

Radar Bug #12015296.

Summary:
Mail in Lion properly responded from the same email address that received the email. Mail in Mountain Lion does not and instead replies from the default email address, regardless of the setting(s) chosen in the preferences.

Steps to Reproduce:
1. Have multiple email accounts, for example, username@me.com and username@company.com.
2. Receive an email to an account that's moved to a folder within Mail, say, "Work" or "Personal."
3. Reply to the email.

Expected Results:
The email reply is created and the sending address is set to the same account that received the email, as in Mail under Mac OS X 10.7/Lion.

Actual Results:
The address used is the first one in the Inboxes, or the one specified in "Send new messages from:" in the "Composing" preferences. Definitively it is NOT the email address to which the email was sent every time, as it was in Lion.

Regression:
This bug is new with Mail in Mountain Lion.

Notes:
I'm told this was filed previously by another user under bug #12013442.

2 Responses to "Mail in Mountain Lion and Replying from the Proper Account"

  1. [...] Erik J. Barzeski: Mail in Lion properly responded from the same email address that received the email. Mail in Mountain Lion does not and instead replies from the default email address, regardless of the setting(s) chosen in the preferences. [...]

  2. I have the same issue, with any message that had been moved (usually via rules) to a folder. Just today upgraded to 10.8.1 and the issue was not resolved. This is extremely annoying. This is new to Mountain Lion.


Trackback URI | Comments RSS

Leave a Reply

Please abide by the comment policy. Valid HTML includes: <blockquote><p>, <em>, <strong>, <ul>, <ol>, and <a href>. Please use the "Quote Me" functionality to quote comments.