Subscribe to
NSLog(); Header Image

Problems with Dock Auto-Hide Keyboard Shortcut

For months now, across a G5 and a Mac Pro, I've had problems with my dock failing to respond to the keyboard shortcut cmd-opt-D to toggle the "Auto-Hide" feature.

I'd press the keys. The dock (which I almost always leave visible) would start to duck down (it's at the bottom of my screen). Then it would spring back up. Checking the menu or the system preference reveals that the auto-hide feature is left in the same state it was in before pressing the keyboard shortcut.

Manually clicking works. Witness this 2.1 MB video.

Things I've tried include:

  • The keyboard shortcut works fine for other users.
  • There are no apparent conflicts in app menus, the Services menu, or defined in Keyboard Shorcuts in the system prefs.
  • It behaves the same regardless of the dock's position on the screen.
  • It behaves the same (again, improperly) when only the Finder is running.
  • It behaves the same with any other dock options set (magnification, zoom effect, etc.).

In short, I can't figure out why I can't make the damn dock toggle its auto-hide settings from the keyboard.

Update: As usually happens (which is, in fact, a large component of the motivation to write posts like this), trying to come up with more items for the list above actually solved the problem. First I tried changing the keyboard shortcut in the system prefs to "cmd-opt-/". The dock exhibited the same behavior. Then I tried "cmd-opt-9" (the 9 above the "i" and "o" keys, not the numpad "9"). It worked. I switched back to "cmd-opt-D" and all is well.

5 Responses to "Problems with Dock Auto-Hide Keyboard Shortcut"

  1. This happens to me as well. In my case I'm 99% sure that it is Textpander causing the problem. I'm using the last free version before it was bought out, and if I disable it the hide-dock shortcut works fine.

  2. Thanks Erik, thanks Graham for post and comment. Textpander is cool, but I don't use it at all - disabling fixes the problem on my Powerbook!

    Changing shortcuts didn't help though ...

  3. I tested Textpander a long time ago (search this blog and you'll see a few such times), so perhaps that's when the problem began. I haven't Texpander in months, though, so perhaps that's why toggling the prefs finally cleared out whatever demon may have been left.

  4. In further testing (the keyboard shortcut stopped working again), TypeIt4Me seems to trigger the bug as well. I can easily turn Ti4M on and off and the keyboard shortcut either fails or works (works when off, fails when on).

  5. I've had this problem for months now and it made me mad. TextExpander was the problem. Thanks! (Alas, I really use TextExpander quite a lot. What can I do?)